Update update update: SA-CORE-2014-005 - Drupal core - SQL injection

So I was eating breakfast and I stumbled on an email in my phone (lots of them but this one caught my eye).
A DRUPAL CRITICAL SECURITY UPDATE FOR Core!

Now, I would like to test such vulnerability if I have the time soon. :D

It's okay now, I have updated my site. Read here for more information.